We're experiencing issues reaching the platform

Incident Report for WeFact

Resolved

The incident has been resolved.
Posted Aug 03, 2026 - 08:47 CEST

Investigating

We are currently investigating the issue.
Posted Aug 03, 2026 - 08:17 CEST
This incident affected: MijnWeFact - Web application.